FuelPHPをインストールしたらfailed to open stream: Permission deniedとか出てくるとき

公開: 2015-05-25 02:28
更新: 2016-04-29 06:03

FuelPHPのv1.7.3が出たようです。

ちょうど新しくWebサイトをちょろっと作成する必要があったので使ってみたいと思います。



あっきぃはzipで落として展開した方がいつもいい感じなので、今回もそうします。

v.1.7.3をダウンロードして、

$ wget http://fuelphp.com/files/download/34

unzipして、

$ unzip 34

とりあえずトップにアクセスすると...

Warning: require(/var/www/html/fuelphp-1.7.3/fuel/vendor/composer/ClassLoader.php): failed to open stream: Permission denied in /var/www/html/fuelphp-1.7.3/fuel/vendor/composer/autoload_real.php on line 12 Fatal error: require(): Failed opening required '/var/www/html/fuelphp-1.7.3/fuel/vendor/composer/ClassLoader.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/fuelphp-1.7.3/fuel/vendor/composer/autoload_real.php on line 12

こんなエラーが出ます。いえい。

何でしょう。fuel/vendor/composer/以下あたりが怪しいです。


じーっと虚空を眺めていても面白くなかったので、
一旦vendorを削除してcomposer updateしてみます。

$ rm -rf fuel/vendor/
$ php composer.phar update

すると表示されました♪

(最新バージョンなんだろうな...)

FuelPHPをインストールしたらfailed to open stream: Permission deniedとか出てくるとき

あと、

$ php composer.phar install

ってやると、tmpとかcacheとかのパーミションを変えてくれる。



⇒ FuelPHP » A simple, flexible, community driven PHP5.3 framework.



この記事をシェア
この記事にコメントする
書き込む
あっきぃ(@appstars_aki)
Web、iOSなフリーランサーです。好きなものはお寿司です。でもお寿司は高いので普段は雑草とか拾ったドングリを食べています。お仕事や意味もなく毎月お小遣いをくれる人を探してます。

お仕事の依頼や自分で作ったアプリのレビューを希望しちゃう方はaki@appstars.jpまでご連絡ください。